Mobile App Payments Delay
Incident Report for ITALS GROUP
Resolved
This incident has been resolved.
Posted Mar 04, 2022 - 07:59 EAT
Investigating
Hello , we are sorry payments via the mobile app is experiencing timeout and delays, we advise our clients to make payments using our Till Number 9482175 as we work to resolve the issue. Sorry for the inconvenience caused. We remain available on our help line incase of any inquiry call/ text/ whatsapp +254-733150181
Posted Mar 02, 2022 - 11:10 EAT
This incident affected: Itals Payments and Itals App.