Web Access Slow
Incident Report for ITALS GROUP
Resolved
This incident has been resolved.
Posted Dec 27, 2021 - 20:54 EAT
Update
We are continuing to monitor for any further issues.
Posted Dec 27, 2021 - 20:53 EAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 27, 2021 - 20:52 EAT
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 27, 2021 - 20:51 EAT
Investigating
We have a confirmed slow website access due to server maintenance with the hosting company, we are working closely with them to have this resolved soonest possible. Sorry for the inconvenience caused
Posted Dec 27, 2021 - 20:50 EAT
This incident affected: Itals Website, Itals Payments, Itals App, and Itals Hosting.