Cloud Server Down
Incident Report for ITALS GROUP
Resolved
The issue has been resolved
Posted Jun 02, 2022 - 21:11 EAT
Investigating
Greetings ! we are sorry to inform you that our main cloud server is timing out and this both our website, email and mobile app are inaccessible. Clients whose their projects are on ITALS GLOBAL SERVER can still access their projects. Our payments gateway via Flutterwave and Tiggy and Safaricom mpesa via remains operational. Our team is working to have this resolved. We are sorry for any inconveniences that this may have caused. Our team are working to have this resolved and we shall communicate as soon as we get this fixed.

Thank You
Lilian M..
Head of Communications
Itals Global LLC
Posted Jun 02, 2022 - 08:48 EAT
This incident affected: Itals Website, Itals App, Itals Hosting, and Itals Support.